Unifi(howto)

From SME Server
Revision as of 05:52, 15 February 2018 by Unnilennium (talk | contribs) (Created page with "install unifi controller on SME 9 {{WIP box}} == Requisites == /sbin/e-smith/db yum_repositories set centos-sclo-rh repository \ Name 'Centos-RH Software collections' \ Bas...")

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

install unifi controller on SME 9


Warning.png Work in Progress:
This page is a Work in Progress. The contents off this page may be in flux, please have a look at this page history the to see list of changes.

Requisites

/sbin/e-smith/db yum_repositories set centos-sclo-rh repository \ Name 'Centos-RH Software collections' \ BaseURL 'http://mirror.centos.org/centos/$releasever/sclo/$basearch/rh/' \ EnableGroups no Visible yes status disabled 

Expand the new repository:

signal-event yum-modify 
yum --enablerepo=centos-sclo-rh,epel install scl-utils rh-mongodb34-mongodb rh-mongodb34-mongodb-server
config set rh-mongodb34-mongod service TCPPort 27018 mongoURL localhost access private status enabled
ln -s /etc/rc.d/init.d/e-smith-service /etc/rc.d/rc7.d/S51rh-mongodb34-mongod

edit file /etc/opt/rh/rh-mongodb34/mongos.conf and change port from 27017 to 27018; disable ipv6 and remove ,::1 from bind ip

service rh-mongodb34-mongod start

or

signal-event post-upgrade;signal-event reboot

Install of unifi controller

Requirements

Operating System:

  • Ubuntu Desktop / Server 14.04 or later (LTS Releases, 16.04 recommended)
  • Debian 7 “Wheezy” or later (LTS Releases, 8 recommended)
  • macOS Mavericks 10.9 or later (10.12 recommended)
  • Windows 7 or later (10 recommended)
  • Windows Server 2008 or later (2016 recommended)

CPU: x86-64 Processor (Intel / AMD x64 Processors)*

RAM: 1GB for Headless Servers; 2GB for GUI*

Network: 100Mbps Wired Ethernet*

HDD: Minimum 10GB free (20GB or more preferred)*

Java: Java Runtime Environment (JRE) 8

Web Browser: Google Chrome

MongoDB: version 2.6.10. (Mongo is offered bundled, so most users will not need to acquire separately. Some distros might use a slightly older version, but v2.6.10 is the one typicallybundled in the Windows/Mac packages, and hence what we will recommend here).

https://help.ubnt.com/hc/en-us/articles/115009221227-UniFi-Recommended-Minimum-System-Requirements

Sources

[Category:Howto]