Talk:Osticket

From SME Server
Jump to: navigation, search

I've installed OSTicket 1.6rc3 in an ibay, rather than follow this howto's instructions on installing in /opt. My steps are below. It works fine, except I can't get email piping to work. Has anyone else managed to get piping to work? Does it matter if it is in an ibay or not?

What is the preferred path for php web apps? /opt with custom html templates, or in ibays?

# 2008-02-04	jlewis
# installing osticket
# create ibay "support"; creates group called "support"
# follow instructions based on http://wiki.contribs.org/Osticket
wget http://www.osticket.com/download/osticket_1.6.rc3.tar.gz
tar zxvf osticket_1.6.rc3.tar.gz
cp -R osticket_1.6.rc3/* /home/e-smith/files/ibays/support/html/.
cd /home/e-smith/files/ibays/support/html/upload
mv * ../.
cd ..
signal-event ibay-modify support
chmod 775 ostconfig.php
mysql -e "create database osticket"
mysql -e "grant all privileges on osticket.* to osticket@localhost identified by 'osticket1'"
mysql -e "flush privileges"
rm index.html
mkdir attachments
chown www attachments
# attempt to get email to support to work with osticket


pico /var/qmail/aliases/.qmail-support 
	# |/home/e-smith/files/ibays/support/html/api/pipe.php
# need to do
	# customize webpages
	# get email pipe functionality to work
	# fall back on pop3 email testing

getting pipping to work should not matter if it is in an ibay or opt dir, try these links below

http://osticket.com/wiki/Email_Settings#POP3

http://osticket.com/wiki/Email_Settings

http://osticket.com/wiki/Email_Templates

also, try these commands from the shell prompt since you are using an ibay

/sbin/e-smith/db accounts setprop support PHPBaseDir /home/e-smith/files/ibays/support/html/:/tmp

/sbin/e-smith/signal-event ibay-modify support


Thanks, i did the above, and when I do the following to send an email to support

mail support

No ticket arrives in osticket.

@4000000047ab134b02e9df5c new msg 3427202
@4000000047ab134b02e9f2e4 info msg 3427202: bytes 353 from <root@arachnerd.com> qp 6447 uid 400
@4000000047ab134b033f9c94 starting delivery 5576: msg 3427202 to local support@gluon.arachnerd.com
@4000000047ab134b033fb404 status: local 2/10 remote 0/20
@4000000047ab134b033fc3a4 delivery 5575: success: forward:_qp_6447/did_0+0+1/
@4000000047ab134b033fd344 status: local 1/10 remote 0/20
@4000000047ab134b033fdefc end msg 3427072
@4000000047ab134b03944c44 delivery 5576: deferral: /bin/sh:_/home/e-smith/files/ibays/support/html/api/pipe.php:_Permission_denied/
@4000000047ab134b039463b4 status: local 0/10 remote 0/20

When I change the contents of /var/qmail/alias/.qmail-support to

|/usr/bin/php -q /home/e-smith/files/ibays/support/html/api/pipe.php

nothing happens in osticket, but I do see this in the qmail log...

[root@gluon ~]# tail /var/log/qmail/current

@4000000047ab10d92f5dc544 delivery 5567: deferral: No_input_file_specified./
@4000000047ab10d92f5dd8cc status: local 0/10 remote 0/20
@4000000047ab11562e6c29b4 starting delivery 5568: msg 3427286 to local support@gluon.arachnerd.com
@4000000047ab11562e6c4124 status: local 1/10 remote 0/20
@4000000047ab1156316823d4 delivery 5568: deferral: No_input_file_specified./
@4000000047ab115631683b44 status: local 0/10 remote 0/20
@4000000047ab11c33093c88c starting delivery 5569: msg 3427291 to local support@gluon.arachnerd.com
@4000000047ab11c33093dffc status: local 1/10 remote 0/20
@4000000047ab11c3338d70ec delivery 5569: deferral: No_input_file_specified./
@4000000047ab11c3338d8474 status: local 0/10 remote 0/20

I made my changes and setup for emails within the admin in osticket and I have no trouble sending and recieving emails, also check the permission settings for pipe.php go to /home/e-smith/files/ibays/support/html/upload/api Make pipe.php executable chmod 764 pipe.php

if your still having trouble, I might suggest removing the ibay support and then follow this howto and see what result you get

Russell