SME8.0 Contribs QA

From SME Server
Revision as of 00:36, 15 September 2012 by Timn (talk | contribs) (Added to a new categorisation page for SME Server project pages)

Contents

Version 8.0 Contrib testing

This document lists Contribs that have had been tested running under SME 8

Contribs should work if they are perl or php based. Some binary application will work as well.

Test guidelines

Considerations_before_installing advises that Contribs for SME 8 have not yet been released, this is to avoid dev workload diagnosing bugs caused by contribs.

Please don't post sme 8 bugs unless you can replicate the bug with the contrib removed or isolated.


Important.png Note:
If you have suggestions, issues or solutions for a contrib, please post them in bugzilla

against the contrib.


Setup

Create a repo named sme7contribs, which points at the SME7 smecontribs repo

db yum_repositories set sme7contribs repository \
GPGCheck yes \
MirrorList http://distro.ibiblio.org/pub/linux/distributions/smeserver/mirrorlist/smecontribs-7 \
Name 'SME 7 - contribs' \
Visible no \
status disabled

signal-event yum-modify
yum clean all


Important.png Note:
now when you will install a package from sme7contribs, you need to use smecontribs to resolve some problems of dependencies...


example :

yum --enablerepo=sme7contribs --enablerepo=smecontribs install smeserver-openvpn-s2s

Contribs

List of Contribs being tested

Working

logwatch

logwatch - Installed from addons repo - seems to work fine afaict

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-adv-samba

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-affa

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-ajaxterm

Ajaxterm - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-arpwatch

Installed and running (ver: smeserver-arpwatch-0.1-2) in a semi-production environment (SME8b6)

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-awstats

AWStats - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-BackupPC

BackupPC To install Backuppc, there is some problemes of dependancies, so you need to refer to this post on the forum [1]

todo :

db yum_repositories set rpmforge repository \
BaseURL 'http://apt.sw.be/redhat/el5/en/$basearch/rpmforge' \
EnableGroups no \
Exclude freetype,htop,iptraf,rsync,syslinux \
GPGCheck yes \
GPGKey http://dag.wieers.com/packages/RPM-GPG-KEY.dag.txt \
Name 'RPMForge - EL5' \
Visible no \
status disabled
signal-event yum-modify
yum install --enablerepo=rpmforge perl-XML-RSS perl-Time-module* perl-File-RsyncP
wget http://repo.firewall-services.com/centos-testing/5/noarch/BackupPC-3.2.0-7.beta0.el5.fws.noarch.rpm
yum localinstall BackupPC-3.2.0-7.beta0.el5.fws.noarch.rpm
signal-event post-upgrade && signal-event reboot

smeserver-bridge-interface

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-bugzilla

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-cacti

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-dar2

Works as expected, although the built in backup to workstation has more functionality (and uses dar)

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-ddclient

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-denyhosts

Denyhosts - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-dimp

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-diskusage

Diskusage - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-durep

A new package will soon be available in sme8 contribs repo, check: http://wiki.contribs.org/Durep

- Installs OK and fully functional.

smeserver-ejabberd

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-ezmlm-web

Installed OK to sme8.0 final and setup one mailing list & tested, works OK, not extensively tested though

- All dependencies are in smecontribs (or from manually configured sme7contribs repo on sme8.0)

smeserver-fetchmail

Fetchmail installs as per wiki, version 1.3.6-17 works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-freepbx

Functionality hasn't been tested beyond ability to install AND update.

Needs atprms-repository configured. Install as per howto[2]

After installing I was able to update FreePBX from 2.6 to 2.9, the latest stable, by using the update function in the FreePBX web-interface.

There are some udev errors while booting, claiming about invalid dahdi.rules. This seems not to be critical. I will post this to the bug-tracker.

smeserver-gallery2

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-geneweb

Geneweb installs as per wiki and works as expected. Not thoroughly tested, but basic functionality (transfering a database form 7.5.1, uploading pictures, restricting access) is available

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-gollem

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-groupmembers-panel

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-groupoffice

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-htbwshaper

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-hwinfo

Hardware Info - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-jeta

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-kplaylist

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-kronolith

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-mailman

Mailman - Mailman contrib causes SME 8 bootstrap-console to hang (need retest after apache fix and dependency updates).

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-mailsorting

Smeserver-mailsorting - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-mailstats

mailstats - sme-mailstats - Install as per wiki

Works as expected.

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-mediawiki

Functionality hasn't been tested beyond ability to install

Install using this post: testing Mediawiki 1.15.1 on SME 8 (may no longer be necessary)

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-mimp

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-mnemo

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-mod_dav

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-mod_deflate

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-mod_python

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-nag

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-nagios

Functionality hasn't been tested beyond ability to install - see Note Nagios about making this work in SME8 (needs to be rechecked with updated pacakges and dependencies)

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-nagios-backup

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-nagiosgrapher

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-nagios-nrpe

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-nagios-nsca

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-nagios-plugins-mysql

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-nfs

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-openoffice-portable

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-openvpn-s2s

Install as per Wiki - Works as expected.

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-openvpn-bridge

Install as per Wiki - Works as expected.

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-oscommerce

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-password

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-phpbb

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-phpki

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-phpldapadmin

Install as per Wiki - Works as expected.

- All dependencies are in smecontribs, smeaddons or smeextras

Note: The version of phpldapadmin supplied in smeserver-phpldapadmin (0.9.8) is old, upgrading to the latest version (1.2.2) is required, refer: http://bugs.contribs.org/show_bug.cgi?id=6895

smeserver-phpsysinfo

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-phpwebftp

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-popfile

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-postgresql

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-print-monitor

LPRng print queue monitor‎ - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-qpsmtpd-spamassassinlevelstars

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-raidmonitor

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-rdiff-backup

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-remoteuseraccess

Smeserver-remoteuseraccess - install as per wiki, bash works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-rkhunter

rkhunter - Installed from contribs repo - seems to work fine afaict

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-sane

SANE - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-sarg

Sarg - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-shared-folders

Functionality hasn't been tested beyond ability to install

by Jáder: I have installed it as by howto.

Just had to use "signal-event post-upgrade && signal-event reboot " because just "expand-template /etc/fstab" do not worked.

I found an error (will put on bugzilla): when creating a share with name longer than limit (12 as standard), just returns an generic ERROR and do not say the cause.

Other than that, it appears to be working I was able to copy to, read, del files.

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-sitemaker

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-smf

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-subversion

subversion Install as per Wiki - Works as expected in SME8b7

- All dependencies are in smecontribs, smeaddons or smeextras


smeserver-teamspeak-server

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-tftp-server

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-thinclient

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

Warning: The contrib allows to specify the TFTP server as "Self". This worked well under SME7 but not under SME8. To get this working under SME8, we had to choose the SME server's IP address to achieve the same result as "self" otherwise the clients cannot find/load from the TFTP server.

We have reported this as bug 6542 for the contrib but with this workaround, the contrib is working well under SME8.

smeserver-tw-logonscript

Smeserver-tw-logonscript Install as per Wiki - Works as expected.

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-typo3

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-unjunkmgr

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-updates

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-usbdisksmanager

Functional, except some error message are present in the panel of the server manager about the interface. will be fixed soon.

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-userpanel

User-manager - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-userpanels

Smeserver-userpanels - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-vacation

Smeserver-vacation - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-wbl

Email#Email_WBL_server_manager_panel - Installs and runs fine as far as I can see.

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-webconsole

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

smeserver-xinetd

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

Workarounds

Contribs that sort of work, but need improvement

smeserver-vmware

The contrib introduces a dependency that cannot be resolved. This dependency is not necessary for sme8. Download vmware-server 2.02 and obtain a license key (you need this during installation in vmware-config.pl).

yum install xinetd
yum localinstall <path-to--rpm-file>/VMware-server-2.0.2-203138.i386.rpm

configure vmware:

vmware-config.pl

and set vmware to autostart and reboot:

ln -s ../init.d/vmware /etc/rc7.d/S19vmware
signal-event post-upgrade; signal-event reboot

Watch the console for a correct start of vmware services. Features like maintenance from external networks, vmware configuration db commands described in the contrib vmware do not work. Use

/etc/init.d/vmware start|stop|restart 

to manage the vmware services. If you do not want vmware server to autostart, remove the symbolic link .

No warranties, Happy VM-ing!

smeserver-zarafa

Zarafa - Because of PHP 5.2.10 in SME8b5 WIP there is a problem with the mapi.so module, see bugzilla:5789:

Tested with:

- SME8b5 WIP
- zarafa-6.40.0 RC2
- smeserver-zarafa-0.9.0-49.el4.sme

User WebSpace

This contribs work followin the steps described here [3]

but without php interpretation. to enable php for users we need to edit the templated istalled with the package:

   /etc/e-smith/templates/etc/httpd/conf/httpd.conf/90e-smithAccess50userdir

and add the following lines:

   AddType application/x-httpd-php .php .php3 .phtml
   AddType application/x-httpd-php-source .phps

in the fragment of code that define "Generic user dir access directive"

after that we expand the modified template and restart the service:

   expand-template /etc/httpd/conf/httpd.conf
   sv h /service/httpd-e-smith

i hope that this hint can help unexperienced users, REDTEO

Broken (or missing dependencies)

smeserver-coova-chilli

smeserver-dansguardian

Dansguardian - install as per wiki, works as expected

dansguardian would likely benefit from rebuilding on a .el5 base

- Needs to have package rebuilt for el5

smeserver-dirty-tools

smeserver-ezmlm-www

smeserver-hylafax

Reported to be working in Forums: http://forums.contribs.org/index.php?topic=48498.new;topicseen#new

smeserver-jinzora

smeserver-joomla

smeserver-moodle

smeserver-oats

smeserver-ocsinventory

smeserver-photos

smeserver-php5-cgi

No longer required as php5 is in SME 8 base

see http://forums.contribs.org/index.php/topic,47647.0.html and also http://bugs.contribs.org/show_bug.cgi?id=6652


smeserver-phpmyadmin

PHPMyAdmin - install as per wiki, works as expected

- All dependencies are in smecontribs, smeaddons or smeextras

phpmyadmin package too old, not supported with php 53, numerous deprecated fucntion, will do a lot of buggy sql request DO NOT USE ! should be adapted to a phpmyadmin http://rpms.famillecollet.com/el5.i386/phpMyAdmin-3.5.2.1-1.el5.remi.noarch.rpm

NOTE: This issue has now been fixed, check: http://bugs.contribs.org/show_bug.cgi?id=7088

smeserver-phpmyadmin-multiuser

Functionality hasn't been tested beyond ability to install

- All dependencies are in smecontribs, smeaddons or smeextras

phpmyadmin package too old, not supported with php 53, numerous deprecated fucntion, will do a lot of buggy sql request DO NOT USE ! should be adapted to a phpmyadmin http://rpms.famillecollet.com/el5.i386/phpMyAdmin-3.5.2.1-1.el5.remi.noarch.rpm

NOTE: This issue has now been fixed, check: http://bugs.contribs.org/show_bug.cgi?id=7088

smeserver-roundcube

Bugzilla:6843

Works for me as follows:

  • install from sme7contribs:
yum enablerepo=sme7contribs install smeserver-roundcube
signal-event post-upgrade; signal-event reboot

At this point, attempting to open roundcube generates the following error in /var/log/messages:

 httpd: PHP Fatal error:  Cannot redeclare quoted_printable_encode() in /opt/roundcube/program/include/rcube_imap.inc on line 2656
  • download the latest sources from sourceforge (0.7.1 as of this writing):

- browse to http://sourceforge.net/projects/roundcubemail/ - click the download button - right-click the 'direct link' url in the download page header, and select 'copy link location' - at a shell prompt on the sme server:

wget <paste link location>
  • extract the downloaded source (replace "roundcubemail-0.7.1.tar.gz" with the actual filename downloaded in step 2):
tar zxvf roundcubemail-0.7.1.tar.gz
  • copy extracted roundcube code on top of the code that was installed by the rpm:
'cp' -rf roundcubemail-0.7.1/* /opt/roundcube
  • Drop and re-create all roundcube tables from mysql (If you're updating an existin roundcube installation you'll need to manually figure out which of the commands in /opt/roundcube/SQL/mysql.update.sql)
mysqldump --add-drop-table --no-data roundcube |grep ^DROP |mysql roundcube
cd /opt/roundcube
mysql roundcube < SQL/mysql.initial.sql

Note: drop all tables using mysqldump courtesy of http://www.thingy-ma-jig.co.uk/comment/7075

Roundcube now opens at http://<my.smeserver.tld>/roundcube

  • Configuration changes (for each user):
    • login and select "Settings" from the top right
    • Folders (do this first)
      • Subscribe to the imap folders you want to access in roundcube. Only subscribed folders are available for selection as 'special folders' in the next step.
    • Preferences
      • Select 'special folders' and set the values you want to use for 'Drafts', 'Sent', 'Junk' and 'Trash'
    • 'Identities'
      • Verify or create a default identity. Create a signature if you want to have one.

smeserver-scuttle

Scuttle - install as per wiki, works as expected

- Needs to have package rebuilt for el5

smeserver-sitex

smeserver-sme7admin

should upgrade to smeserver-sme8admin

yum install smeserver-sme8admin --enablerepo=smetest

smeserver-sysmon

Sysmon UPDATE: A new version of this contrib is now available from the sme8 contribs repo. Fully functional. Check: http://bugs.contribs.org/show_bug.cgi?id=6333

smeserver-tf-b4rt

smeserver-theaddressbook

The Address Book - install as per wiki, works as expected

please take note of http://forums.corvalis.net/viewtopic.php?t=720&highlight=1054 if you have issues with groups

- Needs to have package rebuilt for el5

smeserver-trean

smeserver-webshare

Webshare installs but breaks httpd.conf after creating the first webshare in server manager:

Syntax error on line 1583 of /etc/httpd/conf/httpd.conf:
Invalid command 'AuthUserFile', perhaps misspelled or defined by a module not included in the server configuration
- All dependencies are in smecontribs, smeaddons or smeextras

There is a more detailed workaround explained here:

This workaround works fine on sme8.0 final.

These workarounds have been incorporated into a new package compatible with sme8.0, currently in the sme7 smetest repo, smeserver-webshare-1.0.0-10.el4.sme.noarch.rpm

yum install --enablerepo=smetest smeserver-webshare

(manually enable this repo so your sme8 server can access it)

smeserver-wordpress

smeserver-zabbix-agent

smeserver-zabbix-proxy

smeserver-zabbix-server

Contribs not hosted on contribs.org

Working

cyrus-imap

cyrus-imap - install as per howto, works as expected Refer Forum post

Postgresql and sql-ledger

sql-ledger - install as per howto, works as expected [4]

smeserver-sogo

Sogo - install as per wiki, works as expected

SqueezeBoxServer

Install using the instructions in the howto. Note the advice that you should omit the sections 'Install Perl 5.10.0' and 'Patch Squeezebox server to use Perl5.10.0'.

SystemMonitor

SystemMonitor This is a version from Nethesis which comes very close to smeserver-sysmon functionality. Use deps from sme8contribs. Check: http://forums.contribs.org/index.php?topic=47882.new;topicseen#new

Note: a new version of smeserver-sysmon is now available from the sme8 contrib repo, check: http://bugs.contribs.org/show_bug.cgi?id=6333

smeserver-saco-qmHandle mail queue manager

smeserver-saco-qmHandle Installs OK om sme8.0 final as per wiki. Functionality OK although not extensively tested. This is the version originally from saco services, although at May 2012 the rpm cannot be found on their site. See http://mirror.contribs.org/contribs/rmitchell/smeserver/contribs/qmhandle/smeserver-saco-qmHandle-1.3.4-3.noarch.rpm