Talk:Zarafa quick install script

From SME Server
  • Zarafa 7.0.15 and php53-mapi-7.0.13 do not work together properly. I have created an appointment with the smartphone and this then deleted via web access. This date will not be deleted on the smartphone. With Zarafa 7.0.13 and php53-mapi-7.0.13 which works without problems.
    • Ok, thanks for the test. We need to do some more testing and verification. Was this the only problem you've found pls?
    • I think it should be changed in the script on zarafa 7.0.13, as it definitely leads to problems.
    • At this Moment there is php53-mapi-7.0.13 on EPEL repository not avalible, only php53-mapi-7.1.7
  • Please verify auto detect system architecture and SME Version changes

* TODO: Check if php53-mapi is still required for SME 9 : No ! See Zarafa on SME 9, until SME uses another PHP-version than the one in upstream-CentOS 6.x. In that case another phpXX-mapi is needed --Frifri (talk) 08:02, 7 December 2013 (MST)

    • Ok, then I will exclude the install of php53-mapi in the script if SME 9 is detected. Agree? RequestedDeletion -> YES (--Frifri (talk) 05:07, 8 December 2013 (MST))
    • Excluded php53-mapi replacement for SME9. If this should not be the case, please let me know. RequestedDeletion
  • please do a rpm for this nice software :) --Stephdl (talk) 02:45, 7 December 2013 (MST)
  • For SME 9 :
    • zcp 7.1 : indexer.rpm is replaced with search.rpm
      • Does that mean the current script lacks a templates and config files for the new 'search' component pls? RequestedDeletion -> There are only a few changes in server.cfg and a new search.cfg-template is needed to replace the indexer.cfg-template : http://doc.zarafa.com/7.1/Administrator_Manual/en-US/html-single/index.html#_700to710 As you know, this script always takes the example-config-files of ZCP to make a SME-template from it (cf 'replace'-actions refering to SME-db). (--Frifri (talk) 05:07, 8 December 2013 (MST))
    • check runlevel (rc7.d ?)
      • from the roadmap page: SME Server 9.0 will use runlevel 4. Achieved on Feb 15 with workarounds. We should ask Daniel.