Talk:FreePBX

From SME Server
Jump to: navigation, search
Important.png Note:

Please note that FreePBX is a GUI and Asterisk is the telephony engine. The asterisk engine can load modules that perform specific tasks. One of these (set of) modules is DAHDI. DAHDI is required if you want to connect your Asterisk PBX to e.g. POTS or ISDN for local physical breakout. Before Asterisk 1.6, DAHDI was also required as a timing source for the conference application, but for later Asterisk 1.6 and later this is no longer a dependency.

DAHDI is absolutely NOT required if you only use SIP/IAX2 trunks via a trunk provider for breakout to the telephony network (SS7). So all DADHI issues may not be valid for a lot of users who do not need DAHDI, and FreePBX and Asterisk work perfectly without DAHDI, if you only need SIP/IAX2 trunks.

Even if you do need to break out locally, ATA's or routers with POTS lines come in handy and you don't need DAHDI either, thus keeping your SME Server stable and without any hassle. Therefore I would like to see the FreePBX contrib evolve to a more basic contrib, where DAHDI can be 'activated' after initial install and as a seperate procedure.


retrieve_conf failed to sym link:

  /etc/asterisk/sip_notify.conf from core/etc

This can result in FATAL failures to your PBX. If the target file exists and not identical, the symlink will not occur and you should rename the target file to allow the automatic sym link to occur and remove this error, unless this is an intentional customization.

 mv   /etc/asterisk/sip_notify.conf   /etc/asterisk/sip_notify.conf.old
 ln -s /opt/freepbx/admin/modules/core/etc/sip_notify.conf /etc/asterisk/sip_notify.conf
chown asterisk:asterisk /etc/asterisk/sip_notify.conf

Unnilennium 23:59, 1 November 2012 (MDT)

version for SME8

need to update freepbx framework until at least 2.8 and would be better in http://www.freepbx.org/trac/milestone/2.10 or http://www.freepbx.org/trac/milestone/2.9

as current version of asterisk is 1.6 in sme8

for sme7 should not update after 2.8 as asterisk 1.4 is not supported anymore

17:22, 10 November 2012 (MST)Unnilennium

install on SME8 with kernel >2.6.18-308.21

first get an up to date system

yum update
signal-event post-upgrade; signal-event reboot

add elrepo to your machine

/sbin/e-smith/db yum_repositories set elrepo repository \
Name ' ELRepo.org Community Enterprise Linux Repository - el5' \
BaseURL ' http://elrepo.org/linux/elrepo/el5/$basearch' \
mirrorlist http://elrepo.org/mirrors-elrepo.el5 \
EnableGroups no \
GPGCheck yes \
GPGKey  http://elrepo.org/RPM-GPG-KEY-elrepo.org \
Visible no \
Exclude clamav,spamassassin,libselinux,perl-HTML-Parser,lm_sensors,\
perl-IO-stringy,perl-XML-Parser,razor-agents,libgcrypt,rpm-python,\
libxml2,zlib,gnupg,libxml2-python,yum,module-init-tools,rpm,gettext,\
librpm4,glib2,perl-libwww-perl,perl-Convert-ASN1,beecrypt,fetchmail,\
libacl,libtool-ltdl,popt,libgpg-error,freetype,perl-MIME-tools,mutt,\
gd,perl-TimeDate,librpm4.4 \
status disabled
signal-event yum-modify

install without dependency the last available from smecontribs dahdi-linux rpm, without deps because it requires kmdl that are not available anymore

wget http://mirror.canada.pialasse.com/releases/8.1/smecontribs/i386/RPMS/dahdi-linux-2.4.1-70.el5.i386.rpm
rpm -ivh --nodeps dahdi-linux-2.4.1-70.el5.i386.rpm

install freepbx with kmod

yum --enablerepo=smecontribs --enablerepo=elrepo install smeserver-freepbx kmod-dahdi

then

signal-event post-upgrade; signal-event reboot


then go to your server-manager and update freepbx (up to 2.9 as it it the last version to fully support asterisks16) through its own interface after each version upgrade execute (2.5->2.6->2.7->2.8->2.9)

signal-event freepbx-update

to get access again to the interface.

procedure to update : - go to module admin - click check online - update all available "Upgrade all" - then apply changes and reload ( orange box) - then click check online - select 2.x "Upgrade Tool", install by clicking "process" and follow the instructions ( basically doing the same previous process, but by first updating only the FreePBX Framework, and after applying and reloading all update all other modules)