Sme10BuildQueue

From SME Server
Jump to: navigation, search

This page lists all the packages that SME Server needs to build for SME 10. The starting point is the smeos directory from SME 9. For each package it should be checked if it is still needed, or can we use an upstream package if one is available.


Package Build Steps

check out package

cp -a sme9 sme10
rm -rf sme10/CVS
cd sme10
make clean
mv {sourcedir} {newsourcedir}
  • example e-smith-base-5.2.0 to e-smith-base-5.4.0
rm -f *.patch

{apply any fixes from spec to tree} {move lib/perl5/site_perl to share/perl5/vendor_perl}

tar Jcvf {newsource}.tar.xz {newsourcedir}
vi *.spec
  • remove patches and fixes applied directly to tree
  • bump version and reset release to 1
  • add changelog saying rolling for sme10
make new-sources FILES=*xz
  • will get errors here because no cvs (that's fine)
make mockbuild
  • if this works then we can proceed
rpm -qpl {noarch/x86_64}/{rpmname}.rpm
  • check that files look similar to the sme8 package


These following steps need developer access

They are here for reference, and transparency. They will need to be run on SME Server's build server. You do not need to do this part.

cd ..
cvs add sme10
cd sme10
date +%s
  • get date for import
vi import.log*
  • fix name/version/release and date
cvs add .cvsignore *.spec Makefile import.log sources
  • be sure to add any other needed packages
make commit tag build


  • Current status will be added soon

RPM's from smeos directory

Package Builder status Reference
bglibs-1.102-1.el6.sme.src.rpm daniel build ok
buffer-1.19-7.el6.sme.src.rpm stephdl build ok bugzilla:9233
buildsys-macros-6-1.el7.sme.src.rpm daniel build ok NOT in SMEOS
clamav-0.98.7-1.el6.sme.src.rpm daniel build ok
cpu-1.4.3-14.el6.sme.src.rpm daniel build ok
cvm-0.82-1.el6.sme.src.rpm daniel build ok
daemontools-0.76-6.el6.sme.src.rpm daniel build ok
dar-2.3.8-7.el7.sme.src.rpm daniel build ok NOT in SMEOS

copy from epel to smedev (dar-2.5.2-1.el7.x86_64.rpm)

diald-1.0-3.el6.sme.src.rpm daniel build ok
dietlibc-0.33-0.1600.20110311.el7.sme.src.rpm daniel build ok NOT in SMEOS
djbdns-1.05-8.el6.sme.src.rpm daniel build ok
dot-forward-0.71-4.el6.sme.src.rpm daniel build ok
e-smith-5.4.0-5.el6.sme.src.rpm daniel build ok
e-smith-apache-2.4.0-12.el6.sme.src.rpm daniel build ok bugzilla:9215
e-smith-backup-2.4.0-44.el6.sme.src.rpm daniel build ok
e-smith-base-5.6.0-24.el6.sme.src.rpm daniel build ok bugzilla:9216
e-smith-cvm-unix-local-2.4.0-1.el6.sme.src.rpm daniel build ok
e-smith-devtools-2.4.0-4.el6.sme.src.rpm daniel build ok
e-smith-dnscache-2.4.0-1.el6.sme.src.rpm daniel build ok
e-smith-domains-2.4.0-3.el6.sme.src.rpm daniel build ok
e-smith-dynamicdns-dyndns-2.4.0-1.el6.sme.src.rpm daniel build ok
e-smith-dynamicdns-dyndns.org-2.4.0-1.el6.sme.src.rpm daniel build ok
e-smith-dynamicdns-tzo-2.4.0-1.el6.sme.src.rpm daniel build ok
e-smith-dynamicdns-yi-2.4.0-1.el6.sme.src.rpm daniel build ok
e-smith-email-5.4.0-12.el6.sme.src.rpm daniel build ok bugzilla:9228
e-smith-flexbackup-2.4.0-3.el6.sme.src.rpm stephdl build ok
e-smith-formmagick-2.4.0-1.el6.sme.src.rpm stephdl build ok
e-smith-grub-2.4.0-3.el6.sme.src.rpm stephdl build ok
e-smith-horde-4.4.0-8.el6.sme.src.rpm stephdl build ok
e-smith-hosts-2.4.0-11.el6.sme.src.rpm stephdl build ok
e-smith-ibays-2.4.0-13.el6.sme.src.rpm stephdl build ok
e-smith-imp-5.4.0-2.el6.sme.src.rpm stephdl build ok
e-smith-ingo-2.4.0-1.el6.sme.src.rpm stephdl build ok
e-smith-ldap-5.4.0-19.el6.sme.src.rpm stephdl build ok
e-smith-lib-2.4.0-15.el6.sme.src.rpm stephdl build ok
e-smith-lib-compspec-2.4.0-1.el6.sme.src.rpm stephdl build ok
e-smith-LPRng-2.4.0-1.el6.sme.src.rpm stephdl build ok
e-smith-manager-2.6.0-1.el6.sme.src.rpm stephdl build ok
e-smith-mysql-2.4.0-9.el6.sme.src.rpm stephdl build ok
e-smith-ntp-2.4.0-6.el6.sme.src.rpm daniel build ok bugzilla:9227
e-smith-nutUPS-2.4.0-9.el6.sme.src.rpm stephdl build ok
e-smith-oidentd-2.4.0-1.el6.sme.src.rpm stephdl build ok
e-smith-openssh-2.4.0-6.el6.sme.src.rpm daniel build ok bugzilla:9226
e-smith-packetfilter-2.4.0-3.el6.sme.src.rpm stephdl build ok
e-smith-php-2.4.0-5.el6.sme.src.rpm stephdl build ok
e-smith-pop3-2.4.0-3.el6.sme.src.rpm stephdl build ok
e-smith-portforwarding-2.4.0-1.el6.sme.src.rpm stephdl build ok
e-smith-pptpd-2.4.0-2.el6.sme.src.rpm daniel build ok bugzilla:9225
e-smith-proftpd-2.4.0-3.el6.sme.src.rpm daniel build ok bugzilla:9224
e-smith-proxy-5.4.0-4.el6.sme.src.rpm daniel build ok bugzilla:9223
e-smith-qmail-2.4.0-6.el6.sme.src.rpm daniel build ok bugzilla:9222
e-smith-qmailanalog-2.4.0-1.el6.sme.src.rpm stephdl build ok
e-smith-quota-2.4.0-2.el6.sme.src.rpm stephdl build ok
e-smith-radiusd-2.4.0-10.el6.sme.src.rpm daniel build ok bugzilla:9221
e-smith-runit-2.4.0-2.el6.sme.src.rpm stephdl build ok
e-smith-samba-2.4.0-22.el6.sme.src.rpm daniel build ok bugzilla:9220
e-smith-starterwebsite-2.4.0-3.el6.sme.src.rpm stephdl build ok
e-smith-test-2.4.0-2.el6.sme.src.rpm stephdl build ok
e-smith-tinydns-2.4.0-8.el6.sme.src.rpm stephdl build ok
e-smith-turba-3.4.0-1.el6.sme.src.rpm stephdl build ok
e-smith-viewlogfiles-2.4.0-1.el6.sme.src.rpm stephdl build ok
fastforward-0.51-04.el6.sme.src.rpm stephdl build ok
flexbackup-1.2.1-1.el6.sme.src.rpm daniel build ok
headermatch-0.0.1-3.el6.sme.src.rpm daniel build ok
horde-3.3.11-2.el6.sme.src.rpm daniel build ok
imp-h3-4.3.9-1.el6.sme.src.rpm daniel build ok
ingo-h3-1.2.5-1.el6.sme.src.rpm daniel build ok
ipsvd-0.12.1-7.el6.sme.src.rpm daniel build ok
LPRng-3.8.35-2.el6.sme.src.rpm stephdl build ok bugzilla:9209
mbuffer-20100526-2.el6.sme.src.rpm daniel build ok
mod_perl-2.0.4-11.1.el6.sme.src.rpm FAILED BUILD, WONTFIX bugzilla:9235
perl-CGI-FormMagick-0.93-2.el6.sme.src.rpm daniel build ok
perl-IO-Socket-SSL-1.74-1.el6.sme.src.rpm stephdl build ok copy from centos to smedev (perl-IO-Socket-SSL-1.94-3.el7.noarch.rpm)
perl-Object-Persistence-0.92-5.el6.sme.src.rpm daniel build ok bugzilla:9210
perl-Passwd-Unix-0.71-2.src.rpm daniel build ok NOT in SMEOS
perl-Quota-1.6.7-2.el6.sme.src.rpm daniel build ok
perl-Struct-Compare-1.0.1-1.src.rpm daniel build ok
perl-Test-Harness-Straps-0.30-4.el6.sme.src.rpm daniel build ok
perl-Test-Inline-0.16-1.el6.sme.src.rpm daniel build ok copy from epel to smedev (perl-Test-Inline-2.213-3.el7.noarch.rpm)
ppp-2.4.5-24.el6.sme.src.rpm daniel FAILED BUILD, WONTFIX bugzilla:9211
pptpd-1.3.4-2.el7.sme.src.rpm daniel build ok copy from epel to smedev (pptpd-1.4.0-2.el7.x86_64.rpm)
pwauth-2.3.10-5.el6.sme.src.rpm stephdl build ok copy from epel to smedev (pwauth-2.3.10-9.el7.x86_64.rpm)
qmail-1.03-17.el6.sme.src.rpm daniel build ok
qmailanalog-0.70-8.el6.sme.src.rpm daniel build ok
qpsmtpd-0.84-15.el6.sme.src.rpm daniel build ok bugzilla:9236
qpsmtpd-plugins-0.0.1-4.el6.sme.src.rpm stephdl build ok
runit-2.1.2-1.el6.sme.src.rpm stephdl build ok
smeserver-audittools-1.4.0-3.el6.sme.src.rpm stephdl build ok
smeserver-clamav-2.4.0-4.el6.sme.src.rpm stephdl build ok
smeserver-dovecot-1.4.0-17.el6.sme.src.rpm stephdl build ok
smeserver-locale-2.4.0-22.el6.sme.src.rpm stephdl build ok
smeserver-qpsmtpd-2.4.0-11.el6.sme.src.rpm daniel build ok bugzilla:9230
smeserver-release-9.1-1.el6.sme.src.rpm stephdl build ok
smeserver-spamassassin-2.4.0-5.el6.sme.src.rpm stephdl build ok
smeserver-support-2.6.0-5.el6.sme.src.rpm stephdl build ok
smeserver-yum-2.4.0-11.el6.sme.src.rpm daniel build ok bugzilla:9229
smolt-1.4.3-5.el6.sme.src.rpm stephdl build ok
spamassassin-3.3.2-60.el6.sme.src.rpm daniel FAILED BUILD, WONTIFX bugzilla:9219
tai64nunix-0.70-5.el6.sme.src.rpm daniel build ok
turba-h3-2.3.5-1.el6.sme.src.rpm daniel build ok
ucspi-tcp-0.88-5.el6.sme.src.rpm daniel build ok
ulogd-1.24-13.el6.sme.src.rpm daniel build ok
whiptail-0.51.5-9.el7.sme.src.rpm daniel build ok NOT in SMEOS
xlhtml-0.5-11.el6.sme.src.rpm daniel build ok

Bare install test

install a minimal Centos7 configure network access during installation with option to restore.

yum update -y
yum install nano net-tools mc man htop top iftop iptraf screen openssh-clients mlocate wget vim
  • disable SELinux

SELinux is enabled by default. We want to disable it for there are a few services (e.g. httpd) that get blocked by SELinux. To check the status of SELinux you can enter the command:

getenforce

SELinux uses policies that conflict with some of the SME Server services ports like https. One can adjust the allowed ports, or remove the SELinux policies and disable SELinux by the following commands:

setenforce 0
sed -i -e 's/SELINUX=.*/SELINUX=disabled/g' /etc/selinux/config
yum remove selinux-policy-targeted


  • Enable SSH

SSH is present but is disabled at this stage. To enable ssh issue:

service sshd start

You may have a slow login to ssh, if needed :

vi /etc/ssh/sshd_config

You have to restart the ssh service or the server

  • Reboot system to ensure all new config are permanent
reboot

update packages

yum update

install SME10 repo

vim /etc/yum.repos.d/smeserver10.repo

and paste

[smedev]
enabled=1
MirrorList=http://mirrorlist.contribs.org/mirrorlist/smedev-10
name=SME Server - dev
gpgcheck=1
enablegroups=1
[smetest]
enabled=1
MirrorList=http://mirrorlist.contribs.org/mirrorlist/smetest-10
name=SME Server - dev
gpgcheck=1
enablegroups=1
[smeos]
enabled=1
MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeos-10
name=SME Server - dev
gpgcheck=1
enablegroups=1
 [smeupdates]
enabled=1
MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeupdates-10
name=SME Server - dev
gpgcheck=1
enablegroups=1


install SME10 key

wget http://mirror.contribs.org/releases/testing/10/smeos/x86_64/RPM-GPG-KEY-koozali
rpm --import RPM-GPG-KEY-koozali

install EPEL7 repo

yum install epel-release

then

yum --enablerepo=* clean all

try installing SME10 packages, you might need to enable some repo using --enablerepo=smedev,epel,elrepo ... e.g.

yum install e-smith-* smeserver-* --enablerepo=smedev,smetest,epel,base,updates

or

yum install e-smith-* smeserver-*

you will have to disable postfix :

systemctl stop postfix
systemctl disable postfix

latter it will be good to also deactivate networkManager, to leave network service doing the job, but you also need to configure e-smith db for the server first.

#systemctl stop NetworkManager
#systemctl disable NetworkManager


AT this point ( 2016/03/26 Unnilennium (talk) 13:44, 27 March 2016 (CEST)) you could issue a signal-event post-upgrade; signal-event-reboot; signal-event bootstrap-console-save;signal-event-reboot . But you would have no more network running, as default entry are empty for network. So you are better to expand necessary template using specific event to test each service.

report here

Required dependencies

Important.png Note:
The below list is based on SME10 testing smedev packages and default minimal install of CentOS 7. Enabling the epel and rpmforge repositories will resolve a number of dependencies.

test installation on 2016/06/08

use of http://pkgs.org to fill the blank

fill bug before building e new package : https://bugs.contribs.org/enter_bug.cgi?product=SME%20Server%2010.X&component=build

Package Requiring Required Package Possible sources status Reference
e-smith-base-5.8.0-1.el7.sme.noarch rssh in smedev10 Build OK Bugzilla:9335
smeserver-qpsmtpd-2.6.0-1.el7.sme.noarch perl-MIME-tools in EPEL7 NEEDCOPY perl-MIME-tools-5.505-1.el7.noarch.rpm
e-smith-lib-2.6.0-1.el7.sme.noarch perl(Authen::PAM) in EPEL7 NEEDCOPY perl-Authen-PAM-0.16-16.el7.x86_64.rpm
e-smith-apache-2.6.0-1.el7.sme.noarch mod_authnz_external in EPEL7 NEEDCOPY mod_authnz_external-3.3.1-7.el7.x86_64.rpm
e-smith-base-5.8.0-1.el7.sme.noarch

e-smith-formmagick-2.6.0-1.el7.sme.noarch

e-smith-lib-2.6.0-1.el7.sme.noarch

perl(Crypt::Cracklib) in smedev10 Build OK Bugzilla:9332
e-smith-lib-2.6.0-1.el7.sme.noarch perl(I18N::AcceptLanguage) in smedev10 Build OK Bugzilla:9325
smolt-server-1.4.3-5.el7.sme.noarch mx in centos6 WONTFIX smolt server is deprecated, even if we use the client for a while, we need to find an alternative
e-smith-base-5.8.0-1.el7.sme.noarch vconfig in centos7 NOTABUG vconfig-1.9-16.el7.x86_64.rpm
e-smith-horde-4.6.0-1.el7.sme.noarch php-pear(HTTP) in EPEL7 NEEDCOPY php-pear-HTTP-1.4.1-12.el7.noarch.rpm
e-smith-horde-4.6.0-1.el7.sme.noarch wv in smedev Build OK Bugzilla:9334
smolt-server-1.4.3-5.el7.sme.noarch python-genshi in EPEL7 WONTFIX python-genshi-0.7-3.el7.x86_64.rpm

we will not port the server for sme

e-smith-backup-2.6.0-1.el7.sme.noarch perl(Unix::PasswdFile) in smedev10 Build OK Bugzilla:9338
e-smith-lib-2.6.0-1.el7.sme.noarch

e-smith-base-5.8.0-1.el7.sme.noarch

e-smith-lib-2.6.0-1.el7.sme.noarch

perl(Net::IPv4Addr) >= 0.10 in EPEL7 NEEDCOPY perl-Net-IPv4Addr-0.10-19.el7.noarch.rpm
e-smith-radiusd-2.6.0-1.el7.sme.noarch radiusclient-ng >= 0.5.6 in EPEL7 NEEDCOPY radiusclient-ng-0.5.6-9.el7.x86_64.rpm
e-smith-manager-2.8.0-1.el7.sme.noarch perl-suidperl FIXED Bugzilla:9339 functionality not available on C7

dep removed, will need a lot of code fix later

smeserver-spamassassin-2.6.0-1.el7.sme.noarch razor-agents perl-razor-agents in EPEL7 NEEDCOPY Bugzilla:9336
perl-CGI-FormMagick-0.93-2.el7.sme.noarch

e-smith-lib-2.6.0-1.el7.sme.noarch

perl(Text::Template) in EPEL7 NEEDCOPY perl-Text-Template-1.45-12.el7.noarch.rpm
e-smith-base-5.8.0-1.el7.sme.noarch


smolt-1.4.3-5.el7.sme.noarch

hal NOT AVAILABLE WONTFIX Hal has been dropped, it's no longer available in C7. move to systemd

SMOLT has been removed from smeserver-support requires Bugzilla:9287 need a workaround on this.

need also to remove Requires:HAL Bugzilla:9242

e-smith-domains-2.6.0-1.el7.sme.noarch perl(HTML::Tabulate) >= 0.23 in smedev10 Build OK Bugzilla:9326
dar-2.5.2-1.el7.x86_64 par2cmdline in EPEL7 NEEDCOPY par2cmdline-0.4.tbb.20100203-19.el7.x86_64.rpm
e-smith-base-5.8.0-1.el7.sme.noarch pam_abl REMOVED Bugzilla:9341

template still there, but requires removed

e-smith-nutUPS-2.6.0-2.el7.sme.noarch nut in EPEL7 NEEDCOPY nut-2.7.2-3.el7.x86_64.rpm
smolt-server-1.4.3-5.el7.sme.noarch python-turboflot in Centos6 WONTFIX => we wont port the server for sme10
e-smith-oidentd-2.6.0-1.el7.sme.noarch oidentd >= 2.0.6 in smedev10 Build OK Bugzilla:9340
e-smith-lib-2.6.0-1.el7.sme.noarch

perl-Mojolicious-6.44-2.el7.sme.noarch

perl(Taint::Util) in EPEL7 NEEDCOPY perl-Taint-Util-0.08-3.el7.x86_64.rpm
e-smith-email-5.6.0-1.el7.sme.noarch perl(Net::Server::Fork) in EPEL7 NEEDCOPY perl-Net-Server-2.007-2.el7.noarch.rpm
e-smith-imp-5.6.0-1.el7.sme.noarch php-pear(HTTP_Request) in EPEL7 NEEDCOPY php-pear-HTTP-Request-1.4.4-8.el7.noarch.rpm

php-pear-HTTP-Request2-2.2.1-1.el7.noarch.rpm

perl-Test-Inline-2.213-3.el7.noarch perl(Algorithm::Dependency) >= 1.02 in EPEL7 NEEDCOPY perl-Algorithm-Dependency-1.110-15.el7.noarch.rpm
e-smith-mysql-2.6.0-1.el7.sme.noarch mysql-server mariadb-server in centos7 FIXED Bugzilla:9345

mysql-community-server is accessible in a different repo

smeserver-spamassassin-2.6.0-1.el7.sme.noarch pyzor in centos7 NOTABUG pyzor-0.5.0-10.el7.noarch.rpm
perl-Test-Inline-2.213-3.el7.noarch perl(File::Flat) in EPEL7 NEEDCOPY perl-File-Flat-1.04-15.el7.noarch.rpm
smeserver-qpsmtpd-2.6.0-1.el7.sme.noarch perl-File-MMagic in EPEL7 NEEDCOPY perl-File-MMagic-1.30-1.el7.noarch.rpm
e-smith-viewlogfiles-2.6.0-1.el7.sme.noarch perl(Time::TAI64) in EPEL7 NEEDCOPY perl-Time-TAI64-2.11-1.el7.noarch.rpm
perl-CGI-FormMagick-0.93-2.el7.sme.noarch perl(CGI::Persistent) >= 1.00 in smedev10 Build OK Bugzilla:9329
perl-Test-Inline-2.213-3.el7.noarch perl(Algorithm::Dependency::Source) in EPEL7 NEEDCOPY perl-Algorithm-Dependency-1.110-15.el7.noarch.rpm
e-smith-lib-2.6.0-1.el7.sme.noarch

perl-CGI-FormMagick-0.93-2.el7.sme.noarch

perl(Mail::RFC822::Address) in smedev10 Build OK Bugzilla:9327
e-smith-horde-4.6.0-1.el7.sme.noarch php-pear(Date) in EPEL7 NEEDCOPY php-pear-Date-1.4.7-12.el7.noarch.rpm
perl-Mojolicious-6.44-2.el7.sme.noarch perl(Net::DNS::Native) >= 0.15 in smedev10 Build OK Bugzilla:9333
e-smith-nutUPS-2.6.0-2.el7.sme.noarch nut-client in EPEL7 NEEDCOPY nut-client-2.7.2-3.el7.x86_64.rpm
e-smith-ldap-5.6.0-1.el7.sme.noarch db4-utils libdb4-utils in EPEL7 FIXED new name libdb4-utils-4.8.30-13.el7.x86_64.rpm in EPEL7

Bugzilla:9319, changed Requires: libdb4-utils

perl-Test-Inline-2.213-3.el7.noarch perl(Algorithm::Dependency::Ordered) in EPEL7 NEEDCOPY perl-Algorithm-Dependency-1.110-15.el7.noarch.rpm
e-smith-horde-4.6.0-1.el7.sme.noarch php-pear(Services_Weather) in EPEL7 NEEDCOPY php-pear-Services-Weather-1.4.7-2.el7.noarch.rpm
e-smith-horde-4.6.0-1.el7.sme.noarch php-pear(File) in EPEL7 NEEDCOPY php-pear-File-1.4.1-5.el7.noarch.rpm
e-smith-manager-2.8.0-1.el7.sme.noarch perl(Apache::AuthTkt) in smedev10 Build OK Bugzilla:9311
smolt-1.4.3-5.el7.sme.noarch python-simplejson in Centos 7 NOTABUG python-simplejson-3.3.3-1.el7.x86_64.rpm
e-smith-base-5.8.0-1.el7.sme.noarch pv in EPEL7 NEEDCOPY pv-1.4.6-1.el7.x86_64.rpm
e-smith-formmagick-2.6.0-1.el7.sme.noarch

e-smith-formmagick-2.6.0-1.el7.sme.noarch

e-smith-test-2.6.0-1.el7.sme.noarch

perl(WWW::Automate) >= 0.20 in smedev10 Build OK Bugzilla:9312
imp-h3-4.3.9-1.el7.sme.noarch php-imap >= 4.3.0 in EPEL7 NEEDCOPY php-imap-5.4.16-3.el7.x86_64.rpm

imp-h3 should be drop for horde 5 or else

qpsmtpd-0.84-18.el7.sme.noarch perl(Net::IP) in EPEL7 NEEDCOPY perl-Net-IP-1.26-4.el7.noarch.rpm
e-smith-horde-4.6.0-1.el7.sme.noarch php-pear(Log) in EPEL7 NEEDCOPY php-pear-Log-1.12.8-1.el7.noarch.rpm
smeserver-audittools-1.6.0-1.el7.sme.noarch perl(RPM2) in smedev10 Build OK Bugzilla:9330
e-smith-pptpd-2.6.0-1.el7.sme.noarch pptpd in smedev10 OK pptpd-1.3.4-2.el7.sme.src.rpm / daniel /build ok
smeserver-spamassassin-2.6.0-1.el7.sme.noarch perl(IP::Country) in smedev10 Build OK Bugzilla:9328
smeserver-spamassassin-2.6.0-1.el7.sme.noarch perl(Net::Ident) in smedev10 Build OK Bugzilla:9323
e-smith-base-5.8.0-1.el7.sme.noarch /usr/sbin/cpuspeed WONTFIX Bugzilla:9318 Build OK -

but Bugzilla:9337 Obsolete

perl-Test-Inline-2.213-3.el7.noarch perl(Algorithm::Dependency::Item) in EPEL7 NEEDCOPY perl-Algorithm-Dependency-1.110-15.el7.noarch.rpm
e-smith-manager-2.8.0-1.el7.sme.noarch


e-smith-base-5.8.0-1.el7.sme.noarch

pwauth in smedev10 OK pwauth-2.3.10-5.el6.sme.src.rpm stephdl build ok
perl-Test-Inline-2.213-3.el7.noarch perl(File::chmod) in EPEL7 NEEDCOPY perl-File-chmod-0.40-1.el7.noarch.rpm
e-smith-grub-2.6.0-1.el7.sme.noarch grub grub2 in CentOS7 FIXED C7 has moved to grub2

Bugzilla:9320 changed Requires: grub2 WILL NEED TO ADPT!

perl-CGI-FormMagick-0.93-2.el7.sme.noarch perl(Class::ParamParser) in smedev10 Build OK Bugzilla:9324
mbuffer-20100526-2.el7.sme.x86_64 libmhash.so.2()(64bit) in EPEL7 NEEDCOPY mhash-0.9.9.9-10.el7.x86_64.rpm
e-smith-email-5.6.0-1.el7.sme.noarch perl(Net::Server) >= 0.85 in EPEL7 NEEDCOPY perl-Net-Server-2.007-2.el7.noarch.rpm
e-smith-pop3-2.6.0-1.el7.sme.noarch checkpassword-pam in smedev10 Build OK Bugzilla:9322
e-smith-proftpd-2.6.0-1.el7.sme.noarch proftpd in EPEL7 NEEDCOPY proftpd-1.3.5a-2.el7.x86_64.rpm
e-smith-manager-2.8.0-1.el7.sme.noarch mod_auth_tkt in Repoforge6 Build OK Bugzilla:9310
smeserver-spamassassin-2.6.0-1.el7.sme.noarch DCC in smedev10<Atomic7 Build OK Bugzilla:9331 COPIED from Atomic

But provides dcc not DCC ... Bugzilla:9343

smeserver-qpsmtpd-2.6.0-1.el7.sme.noarch perl-Convert-TNEF in EPEL7 NEEDCOPY perl-Convert-TNEF-0.18-2.el7.noarch.rpm

completed on 2016-03-18

Install SME packages and test

another milestone reached on 2016-03-18 : we were able to install

yum install e-smith-base --enablerepo=smedev,smetest,epel,base,updates

and issue a

/sbin/e-smith/signal-event post-upgrade; /sbin/e-smith/signal-event reboot

wit a system still booting after that :)

we need now to test every base packages and functionality.

Ahead we can think big blocking: - perl-suid need to be replaced - -> systemd - grub -> grub2 -

Horde Testing from John Bennett III

This is taken from an email sent by John to the dev discussion list, which may well contain useful information about configuring the system for testing:

I personally didn't install the e-smith-horde,ingo,imp,turba packages, as those were built for horde 3, and I hadn't tested whether horde would even load using those files. I saw that some of updated horde files were going to be installed, because someone changed the dependency to Requires: horde >= 3.2, which tries to pull them from the centos repo.

I tested what I have built and been using. They loaded fine, and brought in all of the other dependencies.

Webserver wasn't working, enabled it using:

service httpd start or /bin/systemctl start  httpd.service

Permanently enable using:

systemctl enable httpd

Couldn't access webserver.

Also need to stop firewalld for now as well using:

service firewalld stop or /bin/systemctl stop  firewalld.service

For testing, I just disabled it permanently using:

/bin/systemctl disable firewalld.service

to renable:

/bin/systemctl enable firewalld.service

I am now able to access the webserver. Note, I put a sample index.html in the doc root to verify.

I saved a copy of a good httpd.conf, then I did an expand-template /etc/httpd/conf/httpd.conf so that all of the horde information would be there. Re-starting httpd threw an error out, as expected.

I manually changed /etc/httpd/conf.d/ssl.conf and added the alias info. Then manually changed httpd.conf and added all of the horde <Directory parameters, and remarked out the <directory stanzas that deny access to the whole server filesystem. Lines 102-105 for me. Didn't want to waste any additional time figuring out what needs to be really done at this time.

Restarted httpd, then went to webmail, and the page appeared.

Now on to mariabd.

Enabled using:

systemctl enable mariadb
cd /etc/e-smith/templates/etc/e-smith/sql/init/ and started to manually run all of the horde-related scripts.

Notes